CVEvulnerability
CVE-2026-84314
8.7 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-10-12
- Last modified
- 2026-10-13
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-285, CWE-862
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.
Related
References
- https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2 github.com
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1 github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6 github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6 github.com