CVEvulnerability
CVE-2026-84315
8.3 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-10-12
- Last modified
- 2026-10-13
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
- Weaknesses
- CWE-862
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, Nginx UI does not apply RequireSecureSession to multiple authenticated mutation routes even though OTP-enabled users are expected to present a fresh X-Secure-Session-ID for sensitive actions. A stolen authenticated session can therefore create or alter automatic backups, DNS credentials and records, certificates and ACME users, Nginx control settings, and site or stream automation without completing the OTP or passkey step-up. This issue is fixed in version 2.4.1.
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2 github.com
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1 github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-5v7c-xpfp-p65m github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-5v7c-xpfp-p65m github.com