CVEvulnerability
CVE-2026-84360
8.1 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-10-12
- Last modified
- 2026-10-13
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-288
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.
Related
Weakness · CWE (1)
- CWE-288 Authentication Bypass Using an Alternate Path or Channel weakness
References
- https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2 github.com
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1 github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp github.com