CVEvulnerability

CVE-2026-85979

8.6 HIGH Published 2026-09-11 Modified 2026-09-18 Official page ↗
Status
Awaiting Analysis
Published
2026-09-11
Last modified
2026-09-18
Assigner
[email protected]
CVSS 4.0 ([email protected])
8.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weaknesses
CWE-20, CWE-269, CWE-78

Description

Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system.  It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2. This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.

Related

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-269 Improper Privilege Management weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References