CVEvulnerability

CVE-2026-8606

7.0 HIGH Published 2026-05-27 Modified 2026-07-23 Official page ↗
Status
Analyzed
Published
2026-05-27
Last modified
2026-07-23
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.0 HIGH — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-918

Description

A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an attacker to cause the server to issue HTTP requests to internal services via the security advisories package lookup feature. By directing requests to an internal management service and measuring response timing, an attacker could infer the values of sensitive environment variables, including signing secrets and private keys. Exploitation required GitHub Packages to be enabled; on instances not running in private mode the vulnerability was exploitable without authentication, otherwise any authenticated user could exploit it. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21.1 and was fixed in versions 3.20.3, 3.19.7, 3.18.10, 3.17.16, and 3.16.19. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.16.19) • github enterprise server (>= 3.17.0 < 3.17.16) • github enterprise server (>= 3.18.0 < 3.18.10) • github enterprise server (>= 3.19.0 < 3.19.7) • github enterprise server (>= 3.20.0 < 3.20.3) • github enterprise server 3.21.0

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References