CVEvulnerability
CVE-2026-86831
8.7 HIGH
Official page ↗
- Status
- Awaiting Analysis
- Published
- 2026-09-16
- Last modified
- 2026-10-20
- Assigner
- ff89ba41-3aa1-4d27-914a-91399e9639e5
- CVSS 4.0 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
- 8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
- 8.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-1289
Description
Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS Network Policy Agent before v1.4.0 might allow an authenticated remote user to bypass NetworkPolicy enforcement on co-located pods in other namespaces via crafted pod and namespace names that produce pod identifier collisions.
To remediate this issue, users should upgrade to Amazon EKS Network Policy Agent 1.4.0 or later and Amazon VPC CNI Managed Add-on v1.22.4 or later (which includes Network Policy Agent v1.4.0).
Related
Weakness · CWE (1)
- CWE-1289 Improper Validation of Unsafe Equivalence in Input weakness
References
- https://aws.amazon.com/security/security-bulletins/2026-113-aws/ aws.amazon.com
- https://github.com/aws/amazon-vpc-cni-k8s/releases/tag/v1.22.4 github.com
- https://github.com/aws/amazon-vpc-cni-k8s/security/advisories/GHSA-gjc7-c7mx-x8f3 github.com
- https://github.com/aws/aws-network-policy-agent/releases/tag/v1.4.0 github.com
- https://github.com/aws/aws-network-policy-agent/security/advisories/GHSA-7xv7-8r3j-3j25 github.com