CVEvulnerability
CVE-2026-87911
9.0 CRITICAL
Official page ↗
- Status
- Deferred
- Published
- 2026-09-09
- Last modified
- 2026-09-10
- Assigner
- ff89ba41-3aa1-4d27-914a-91399e9639e5
- CVSS 4.0 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
- 9.0 CRITICAL — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
- 9.6 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-184, CWE-78
Description
An OS command injection weakness in the read-only enforcement of the SQL validation component in Amazon awslabs postgres-mcp-server before 1.1.7 might allow an unauthenticated actor to execute operating system commands on the host of a self-managed PostgreSQL server by placing a crafted COPY ... TO PROGRAM statement into content that is processed when an authenticated user interacts with the MCP server in its default read-only mode.
To remediate this issue, users should upgrade to version 1.1.7 or later.