CVEvulnerability

CVE-2026-88920

9.8 CRITICAL Published 2026-09-30 Modified 2026-10-02 Official page ↗
Status
Analyzed
Published
2026-09-30
Last modified
2026-10-02
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287

Description

An authentication bypass in the DOM security processor in Apache WSS4J allows unauthenticated remote attackers to forge authenticated SOAP messages via a crafted unsigned SAML sender-vouches assertion containing an attacker-controlled key. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.

Affected configurations

• apache wss4j (< 2.4.4) • apache wss4j (>= 3.0.0 < 3.0.6) • apache wss4j (>= 4.0.0 < 4.0.2)

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References