CVEvulnerability

CVE-2026-9106

4.8 MEDIUM Published 2026-06-30 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-06-30
Last modified
2026-10-25
Assigner
[email protected]
CVSS 4.0 ([email protected])
4.8 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
5.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
Weaknesses
CWE-451

Description

A UI misrepresentation vulnerability was identified in GitHub Enterprise Server that allowed an OAuth application to gain unintended access to an organization's runner management. An attacker could exploit this by creating an OAuth application requesting the manage_runners:org scope and directing a victim user to authorize it, as the scope was not displayed on the authorization consent screen. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.16.20) • github enterprise server (>= 3.17.0 < 3.17.17) • github enterprise server (>= 3.18.0 < 3.18.11) • github enterprise server (>= 3.19.0 < 3.19.8) • github enterprise server (>= 3.20.0 < 3.20.4) • github enterprise server (>= 3.21.0 < 3.21.2)

Related

Weakness · CWE (1)

  • CWE-451 User Interface (UI) Misrepresentation of Critical Information weakness

References