CVEvulnerability
CVE-2026-91863
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-09-21
- Last modified
- 2026-09-24
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-674
Description
A specially crafted WS-Policy document with deeply nested policy elements can bypass Neethi's nesting-depth limit and exhaust the thread stack, crashing the parser (denial of service).
Users are recommended to upgrade to version 3.2.4, which fixes this issue.
Affected configurations
• apache neethi (< 3.2.4)
Related
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://lists.apache.org/thread/72kxj71lvrqqx90xxqqctvpbw0t8mpxw Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/09/18/10 Mailing List, Third Party Advisory