CVEvulnerability

CVE-2026-9312

9.2 CRITICAL Published 2026-05-27 Modified 2026-07-23 Official page ↗
Status
Modified
Published
2026-05-27
Last modified
2026-07-23
Assigner
[email protected]
CVSS 4.0 ([email protected])
9.2 CRITICAL — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-918

Description

A server-side request forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to send crafted requests to internal services by exploiting insufficient input validation in an upload endpoint. By injecting path traversal content into request parameters, an attacker could bypass the intended request flow and redirect internal API calls, potentially accessing internal services and exposing sensitive credentials. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.17, 3.18.11, 3.19.8, 3.20.4, and 3.21.2. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (>= 3.16.0 < 3.16.19) • github enterprise server (>= 3.17.0 < 3.17.16) • github enterprise server (>= 3.18.0 < 3.18.10) • github enterprise server (>= 3.19.0 < 3.19.7) • github enterprise server (>= 3.20.0 < 3.20.3) • github enterprise server 3.21.1

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References