CVEvulnerability
CVE-2026-94212
6.4 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-10-01
- Last modified
- 2026-10-01
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.4 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-347
Description
Improper verification of cryptographic signature vulnerability in Apache APISIX.
Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Related
Weakness · CWE (1)
- CWE-347 Improper Verification of Cryptographic Signature weakness
References
- https://lists.apache.org/thread.html/1230fnojnmc7bfz3n0nkt7tkcld9d1sc lists.apache.org
- http://www.openwall.com/lists/oss-security/2026/10/01/4 www.openwall.com