CVEvulnerability
CVE-2026-94276
5.1 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-10-01
- Last modified
- 2026-10-01
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.1 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-287
Description
Improper Authentication vulnerability in Apache APISIX.
On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://lists.apache.org/thread.html/txn3br25kl657fh15rwcy1oht1xbpyyk lists.apache.org
- http://www.openwall.com/lists/oss-security/2026/10/01/8 www.openwall.com