CVEvulnerability
CVE-2026-94636
8.2 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-10-02
- Last modified
- 2026-10-02
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.2 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-1284, CWE-409, CWE-628
Description
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Related
References
- https://lists.apache.org/thread/1rpq0d0g6yzjjzl1z27lwmvhzkn6rbrs lists.apache.org
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1 lists.apache.org