GitHub Advisoryadvisory · Packagist
GHSA-222v-cx2c-q2f5 phpMyAdmin XSS when checking tables
MEDIUM
Official page ↗
- Aliases
- CVE-2025-24530
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-01-23
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.2.2 → fixed in 5.2.2
Description
An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.
Related
Alias · CVE (1)
- CVE-2025-24530 An issue was discovered in phpMyAdmin 5.x before 5.2.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-24530 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/23c13a81709728089ff031e5b1c29b5e91baa6a7 web
- https://github.com/phpmyadmin/phpmyadmin package
- https://lists.debian.org/debian-lts-announce/2025/04/msg00016.html web
- https://www.phpmyadmin.net/security/PMASA-2025-1 web