GitHub Advisoryadvisory · Maven
GHSA-223m-pgcq-f3xg Jenkins Fortify Plugin HTML injection vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-4303
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:fortify
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-08-22
Affected packages
• Maven org.jenkins-ci.plugins:fortify: < 22.2.39 → fixed in 22.2.39
Description
Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method. This results in an HTML injection vulnerability.
Fortify Plugin 22.2.39 removes HTML tags from the error message.
Related
Alias · CVE (1)
- CVE-2023-4303 Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method, resulting in an HTML injection… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness