GitHub Advisoryadvisory · PyPI
GHSA-227r-w5j2-6243 InvokeAI Arbitrary File Deletion vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2024-11042
- Ecosystem
- PyPI
- Packages
- InvokeAI
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-20, CWE-22, CWE-73
- Reviewed
- 2025-03-21
Affected packages
• PyPI InvokeAI: < 5.3.0rc1 → fixed in 5.3.0rc1
Description
In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. This vulnerability allows unauthorized attackers to delete arbitrary files on the server, potentially including critical or sensitive system files such as SSH keys, SQLite databases, and configuration files. This can impact the integrity and availability of applications relying on these files.
Related
Alias · CVE (1)
- CVE-2024-11042 In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-11042 advisory
- https://github.com/invoke-ai/invokeai/commit/5440c037674882b2ab7acd59087e9bb04b49657a web
- https://github.com/invoke-ai/InvokeAI package
- https://github.com/pypa/advisory-database/tree/main/vulns/invokeai/PYSEC-2026-358.yaml web
- https://huntr.com/bounties/635535a7-c804-4789-ac3a-48d951263987 web
- https://pypi.org/project/invokeai web