GitHub Advisoryadvisory · Go

GHSA-227x-7mh8-3cf6 Gardener provider extensions vulnerable to code injection when Terraform is used for infrastructure provisioning

CRITICAL Published 2025-09-25 Modified 2025-10-23 Official page ↗
Aliases
CVE-2025-59823
Ecosystem
Go
Packages
github.com/gardener/gardener-extension-provider-aws, github.com/gardener/gardener-extension-provider-gcp, github.com/gardener/gardener-extension-provider-azure, github.com/gardener/gardener-extension-provider-openstack
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-94
Reviewed
2025-09-25

Affected packages

• Go github.com/gardener/gardener-extension-provider-aws: < 1.64.0 → fixed in 1.64.0 • Go github.com/gardener/gardener-extension-provider-gcp: < 1.46.0 → fixed in 1.46.0 • Go github.com/gardener/gardener-extension-provider-azure: < 1.55.0 → fixed in 1.55.0 • Go github.com/gardener/gardener-extension-provider-openstack: < 1.49.0 → fixed in 1.49.0

Description

Impact A security vulnerability was discovered in Gardener when Terraformer is used for infrastructure provisioning. This vulnerability could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster where the shoot cluster is managed. This CVE affects all Gardener installations where Terraformer is used/can be enabled for infrastructure provisioning with any of the affected components mentioned below. Affected Components • gardener-extension-provider-gcp • gardener-extension-provider-azure • gardener-extension-provider-openstack • gardener-extension-provider-aws Affected Versions • gardener-extension-provider-gcp = v1.46.0 • gardener-extension-provider-azure >= v1.55.0 • gardener-extension-provider-openstack >= v1.49.0 • gardener-extension-provider-aws >= v1.64.0 How do I mitigate this vulnerability? Update to a fixed version.

Related

Alias · CVE (1)

  • CVE-2025-59823 Project Gardener implements the automated management and operation of Kubernetes clusters as a service. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-94 Improper Control of Generation of Code weakness

References