GitHub Advisoryadvisory · PyPI

GHSA-22jr-vc7j-g762 Potential buffer overflow in psd-tools

CRITICAL Published 2020-03-16 Modified 2026-09-24 Official page ↗
Aliases
CVE-2020-10571
Ecosystem
PyPI
Packages
psd-tools
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-754
Reviewed
2020-03-16

Affected packages

• PyPI psd-tools: >= 1.8.37, < 1.9.4 → fixed in 1.9.4

Description

Impact An issue was discovered in psd-tools before 1.9.4. The Cython implementation of RLE decoding did not check for malformed PSD input data during decoding to the PIL.Image or NumPy format, leading to a Buffer Overflow. Patches Users of psd-tools version v1.8.37 to v1.9.3 should upgrade to v1.9.4. Workarounds Without Cython present on installation, buffer overflow does not occur but IndexError will be thrown. However, already installed psd-tools with Cython extention should be upgraded. References https://github.com/psd-tools/psd-tools/pull/198 For more information If you have any questions or comments about this advisory: • Open an issue in psd-tools

Related

Alias · CVE (1)

  • CVE-2020-10571 An issue was discovered in psd-tools before 1.9.4. vulnerability

Weakness · CWE (1)

  • CWE-754 Improper Check for Unusual or Exceptional Conditions weakness

References