GitHub Advisoryadvisory · Packagist
GHSA-22q7-cg4r-p9mx TYPO3 Cross-Site Scripting in Fluid ViewHelpers
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- typo3/cms-fluid
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-30
Affected packages
• Packagist typo3/cms-fluid: >= 8.0.0, < 8.7.23 → fixed in 8.7.23
• Packagist typo3/cms-fluid: >= 9.0.0, < 9.5.4 → fixed in 9.5.4
Description
Failing to properly encode user input, templates using built-in Fluid ViewHelpers are vulnerable to cross-site scripting.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/TYPO3-CMS/fluid/commit/1a65dcc4a8f17f61a8055c0fd46c324c44c9980d web
- https://github.com/TYPO3-CMS/fluid/commit/a40f468d1534a68cfce91ce2a8e2a1ff81db5cf5 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/2019-01-22-4.yaml web
- https://github.com/TYPO3-CMS/fluid package
- https://github.com/TYPO3-CMS/fluid/compare/v8.7.22...v8.7.23 web
- https://github.com/TYPO3-CMS/fluid/compare/v9.5.3...v9.5.4 web
- https://typo3.org/security/advisory/typo3-core-sa-2019-005 web