GitHub Advisoryadvisory · Packagist
GHSA-232p-59mg-f98p Microweber Cross-site Scripting can result in redirection to a malicious site
MEDIUM
Official page ↗
- Aliases
- CVE-2022-3242
- Ecosystem
- Packagist
- Packages
- microweber/microweber
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-21
Affected packages
• Packagist microweber/microweber: < 1.3.2 → fixed in 1.3.2
Description
Microweber versions 1.3.1 and prior are vulnerable to HTML injection that an attacker can use to redirect someone to a malicious site. A patch is available at commit 68f0721571653db865a5fa01c7986642c82e919c and expected to be part of version 1.3.2.
Related
Alias · CVE (1)
- CVE-2022-3242 Code Injection in GitHub repository microweber/microweber prior to 1.3.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness