GitHub Advisoryadvisory · PyPI

GHSA-237r-mx84-7x8c VNCAuthProxy authentication bypass vulnerability

CRITICAL Published 2022-09-16 Modified 2024-11-18 Official page ↗
Aliases
CVE-2022-36436
Ecosystem
PyPI
Packages
vncauthproxy
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
Reviewed
2022-09-16

Affected packages

• PyPI vncauthproxy: < 1.2.0 → fixed in 1.2.0

Description

OSU Open Source Lab VNCAuthProxy through 1.1.1 is affected by an vncap/vnc/protocol.py VNCServerAuthenticator authentication-bypass vulnerability that could allow a malicious actor to gain unauthorized access to a VNC session or to disconnect a legitimate user from a VNC session. A remote attacker with network access to the proxy server could leverage this vulnerability to connect to VNC servers protected by the proxy server without providing any authentication credentials. Exploitation of this issue requires that the proxy server is currently accepting connections for the target VNC server.

Related

Alias · CVE (1)

  • CVE-2022-36436 OSU Open Source Lab VNCAuthProxy through 1.1.1 is affected by an vncap/vnc/protocol.py VNCServerAuthenticator authentication-bypass… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References