GitHub Advisoryadvisory · npm
GHSA-238x-w2j9-gwwr Payload vulnerable to API key disclosure through ordinary document reads
HIGH
Official page ↗
- Aliases
- CVE-2026-105849
- Ecosystem
- npm
- Packages
- payload
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Weaknesses
- CWE-201, CWE-862
- Reviewed
- 2026-10-06
Affected packages
• npm payload: >= 3.0.0, < 3.90.0 → fixed in 3.90.0
• npm payload: >= 4.0.0-canary.0, < 4.0.0-canary.34 → fixed in 4.0.0-canary.34
Description
Impact
Users with read access to other user documents could access their active API keys. An exposed key grants the target account’s permissions until rotated or disabled.
You are affected if:
• An authentication collection enables `useAPIKey`.
• Users have read access to other user documents containing active API keys.
Patches
Users should upgrade payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
Workarounds
Disable `useAPIKey` or restrict users to reading only their own authentication document. Rotate any API key that may have been exposed.
Related
Alias · CVE (1)
- CVE-2026-105849 Payload is a free and open source headless content management system. vulnerability