GitHub Advisoryadvisory · Maven
GHSA-23cr-5hr4-rgwv Improper Input Validation in Apache ActiveMQ
MEDIUM
Official page ↗
- Aliases
- CVE-2015-6524
- Ecosystem
- Maven
- Packages
- org.apache.activemq:activemq-broker, org.apache.activemq:activemq-jaas
- Severity
- Moderate
- Weaknesses
- CWE-20
- Reviewed
- 2022-07-06
Affected packages
• Maven org.apache.activemq:activemq-broker: >= 5.0.0, < 5.10.2 → fixed in 5.10.2
• Maven org.apache.activemq:activemq-jaas: >= 5.0.0, < 5.10.2 → fixed in 5.10.2
Description
The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.
Related
Alias · CVE (1)
- CVE-2015-6524 The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-6524 advisory
- https://github.com/apache/activemq/commit/22f2f3dde757d31307da772d579815c1d169bc39 web
- https://github.com/apache/activemq web
- http://activemq.apache.org/security-advisories.data/CVE-2014-3612-announcement.txt web
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168094.html web
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168651.html web