GitHub Advisoryadvisory · npm
GHSA-23vw-mhv5-grv5 Denial of Service in @hapi/hapi
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- @hapi/hapi
- Severity
- High
- Reviewed
- 2020-08-31
Affected packages
• npm @hapi/hapi: < 18.4.1 → fixed in 18.4.1
• npm @hapi/hapi: >= 19.0.0, < 19.1.1 → fixed in 19.1.1
Description
Versions of `@hapi/hapi` prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.
Recommendation
Upgrade to versions 18.4.1, 19.1.1 or later.