GitHub Advisoryadvisory · RubyGems
GHSA-242p-4v39-2v8g Cross-site Scripting (XSS) possible with maliciously formed HTML attribute names and values in Phlex
HIGH
Official page ↗
- Aliases
- CVE-2024-28199
- Ecosystem
- RubyGems
- Packages
- phlex
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-03-12
Affected packages
• RubyGems phlex: >= 1.9.0, < 1.9.1 → fixed in 1.9.1
• RubyGems phlex: >= 1.8.0, < 1.8.2 → fixed in 1.8.2
• RubyGems phlex: >= 1.7.0, < 1.7.1 → fixed in 1.7.1
• RubyGems phlex: >= 1.6.0, < 1.6.2 → fixed in 1.6.2
• RubyGems phlex: >= 1.5.0, < 1.5.2 → fixed in 1.5.2
• RubyGems phlex: >= 1.4.0, < 1.4.1 → fixed in 1.4.1
• RubyGems phlex: >= 1.3.0, < 1.3.3 → fixed in 1.3.3
• RubyGems phlex: >= 1.2.0, < 1.2.2 → fixed in 1.2.2
• RubyGems phlex: >= 1.1.0, < 1.1.1 → fixed in 1.1.1
• RubyGems phlex: < 1.0.1 → fixed in 1.0.1
Description
There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. This was due to improper case-sensitivity in the code that was meant to prevent these attacks.
Impact
If you render an `` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user.
```ruby
a(href: user_profile) { "Profile" }
```
If you splat user-provided attributes when rendering any HTML or SVG tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user.
```ruby
h1(**JSON.parse(user_attributes))
```
Patches
Patches are available on RubyGems for all `1.x` minor versions. The patched versions are:
• 1.9.1
• 1.8.2
• 1.7.1
• 1.6.2
• 1.5.2
• 1.4.1
• 1.3.3
• 1.2.2
• 1.1.1
• 1.0.1
If you are on `main`, it has been patched since `aa50c60`
Workarounds
Configuring a Content Security Policy that does not allow `unsafe-inline` would effectively prevent this vulnerability from being exploited.
References
In addition to upgrading to a patched version of Phlex, we strongly recommend configuring a Content Security Policy header that does not allow `unsafe-inline`. Here’s how you can configure a Content Security Policy header in Rails. https://guides.rubyonrails.org/security.html#content-security-policy-header
Related
Alias · CVE (1)
- CVE-2024-28199 phlex is an open source framework for building object-oriented views in Ruby. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/phlex-ruby/phlex/security/advisories/GHSA-242p-4v39-2v8g web
- https://nvd.nist.gov/vuln/detail/CVE-2024-28199 advisory
- https://github.com/phlex-ruby/phlex/commit/aa50c604cdee1d0ce7ef068a4c66cbd5d43f96a1 web
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy web
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline web
- https://github.com/phlex-ruby/phlex package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/phlex/CVE-2024-28199.yml web