GitHub Advisoryadvisory · Packagist

GHSA-2528-jw5q-ww88 phpseclib: guardrails needed on isPrime and randomPrime

HIGH Published 2026-05-06 Modified 2026-05-06 Official page ↗
Aliases
CVE-2024-27354
Ecosystem
Packagist
Packages
phpseclib/phpseclib
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2026-05-06

Affected packages

• Packagist phpseclib/phpseclib: >= 0.1.1, < 1.0.23 → fixed in 1.0.23 • Packagist phpseclib/phpseclib: >= 2.0.0, < 2.0.47 → fixed in 2.0.47 • Packagist phpseclib/phpseclib: >= 3.0.0, < 3.0.36 → fixed in 3.0.36

Description

Impact Anyone trying to generate a prime and testing the primality of a number. Patches https://github.com/phpseclib/phpseclib/commit/ad5dbdf2129f5e0fb644637770b7f33de8ca8575 Workarounds Using the GMP extension would probably help, assuming that one has its own guardrails. Resources https://github.com/phpseclib/phpseclib/commit/ad5dbdf2129f5e0fb644637770b7f33de8ca8575 https://www.usenix.org/system/files/conference/usenixsecurity25/sec25cycle1-prepub-599-shi-bing.pdf

Related

Alias · CVE (1)

  • CVE-2024-27354 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References