GitHub Advisoryadvisory · Go
GHSA-2549-xh72-qrpm Mattermost Improper Validation of Specified Type of Input vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-20033
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-1287
- Reviewed
- 2025-01-09
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.16 → fixed in 9.11.16
• Go github.com/mattermost/mattermost/server/v8: >= 10.0.0, < 10.0.4 → fixed in 10.0.4
• Go github.com/mattermost/mattermost/server/v8: >= 10.1.0, < 10.1.4 → fixed in 10.1.4
• Go github.com/mattermost/mattermost/server/v8: >= 10.2.0, < 10.2.1 → fixed in 10.2.1
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250102081831-64c566a8280b → fixed in 8.0.0-20250102081831-64c566a8280b
Description
Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows attackers to deny service to users with the sysconsole_read_plugins permission via creating a post with the custom_pl_notification type and specific props.
Related
Alias · CVE (1)
- CVE-2025-20033 Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows… vulnerability
Weakness · CWE (1)
- CWE-1287 Improper Validation of Specified Type of Input weakness