GitHub Advisoryadvisory · RubyGems

GHSA-254j-mmc5-qhpx Smashing Cross-site Scripting vulnerability

MEDIUM Published 2022-05-24 Modified 2023-01-27 Official page ↗
Aliases
CVE-2021-35440
Ecosystem
RubyGems
Packages
smashing
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-01-27

Affected packages

• RubyGems smashing: < 1.3.5 → fixed in 1.3.5

Description

Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.

Related

Alias · CVE (1)

  • CVE-2021-35440 Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References