GitHub Advisoryadvisory · PyPI
GHSA-2586-f3p4-hq84 LightGBM Remote Code Execution Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-43598
- Ecosystem
- PyPI
- Packages
- lightgbm
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C
- Weaknesses
- CWE-122
- Reviewed
- 2025-02-18
Affected packages
• PyPI lightgbm: >= 1.0.0, < 4.6.0 → fixed in 4.6.0
Description
LightGBM Remote Code Execution Vulnerability
Related
Alias · CVE (1)
- CVE-2024-43598 LightGBM Remote Code Execution Vulnerability vulnerability
Weakness · CWE (1)
- CWE-122 Heap-based Buffer Overflow weakness