GitHub Advisoryadvisory · npm

GHSA-25mp-g6fv-mqxx Unexpected server crash in Next.js.

HIGH Published 2021-12-07 Modified 2024-03-13 Official page ↗
Aliases
CVE-2021-43803
Ecosystem
npm
Packages
next
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2021-12-06

Affected packages

• npm next: >= 12.0.0, < 12.0.5 → fixed in 12.0.5 • npm next: >= 0.9.9, < 11.1.3 → fixed in 11.1.3

Description

Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue. Note that prior version 0.9.9 package `next` hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References