GitHub Advisoryadvisory · Packagist
GHSA-25wf-7x6c-wmpf Moodle does not properly enforce MFA
MEDIUM
Official page ↗
- Aliases
- CVE-2025-62398
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2025-10-24
Affected packages
• Packagist moodle/moodle: >= 5.0.0-beta, < 5.0.3 → fixed in 5.0.3
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.7 → fixed in 4.5.7
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.11 → fixed in 4.4.11
Description
A serious authentication flaw allowed attackers with valid credentials to bypass multi-factor authentication under certain conditions, potentially compromising user accounts.
Related
Alias · CVE (1)
- CVE-2025-62398 A serious authentication flaw allowed attackers with valid credentials to bypass multi-factor authentication under certain conditions,… vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-62398 advisory
- https://github.com/moodle/moodle/commit/67005f8b2098096f4c7ca4f78ab9ce69415d703b web
- https://github.com/moodle/moodle/commit/a2078f781ae065ca1f781bd159c7615c84afcaa5 web
- https://access.redhat.com/security/cve/CVE-2025-62398 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2404431 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=470387 web