GitHub Advisoryadvisory · Maven
GHSA-25xc-jwfq-39jw OSGi applications using Vaadin 12-14 and 19 vulnerable to server classes and resources exposure
HIGH
Official page ↗
- Aliases
- CVE-2021-31407
- Ecosystem
- Maven
- Packages
- com.vaadin:flow-server
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-402, CWE-668
- Reviewed
- 2021-04-16
Affected packages
• Maven com.vaadin:flow-server: >= 1.2.0, < 2.4.8 → fixed in 2.4.8
• Maven com.vaadin:flow-server: >= 6.0.0, < 6.0.1 → fixed in 6.0.1
Description
Vulnerability in OSGi integration in `com.vaadin:flow-server` versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.
• https://vaadin.com/security/cve-2021-31407
Related
Alias · CVE (1)
- CVE-2021-31407 Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through… vulnerability
References
- https://github.com/vaadin/flow/security/advisories/GHSA-25xc-jwfq-39jw web
- https://nvd.nist.gov/vuln/detail/CVE-2021-31407 advisory
- https://github.com/vaadin/osgi/issues/50 web
- https://github.com/vaadin/flow/pull/10229 web
- https://github.com/vaadin/flow/pull/10269 web
- https://github.com/vaadin/flow package
- https://vaadin.com/security/cve-2021-31407 web