GitHub Advisoryadvisory · Packagist
GHSA-264g-f7v8-q5qq Magento Open Source allows Cross-Site Scripting (XSS)
HIGH
Official page ↗
- Aliases
- CVE-2024-20719
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p4 → fixed in 2.4.6-p4
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p6 → fixed in 2.4.5-p6
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p7 → fixed in 2.4.4-p7
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into every admin page. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field, that could be leveraged to gain admin access.
Related
Alias · CVE (1)
- CVE-2024-20719 Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness