GitHub Advisoryadvisory · Maven
GHSA-264w-xrr7-6qqg RCE vulnerability in Jenkins OpenShift Pipeline Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2167
- Ecosystem
- Maven
- Packages
- com.openshift.jenkins:openshift-pipeline
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20, CWE-502
- Reviewed
- 2022-12-28
Affected packages
• Maven com.openshift.jenkins:openshift-pipeline: < 1.0.57 → fixed in 1.0.57
Description
OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to provide YAML input files to OpenShift Pipeline Plugin’s build step. OpenShift Pipeline Plugin 1.0.57 configures its YAML parser to only instantiate safe types.
Related
Alias · CVE (1)
- CVE-2020-2167 Jenkins OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types,… vulnerability