GitHub Advisoryadvisory · Packagist
GHSA-265q-222x-52m6 silverstripe/framework has potential SQL Injection vulnerability in PostgreSQL database connector
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- silverstripe/framework
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-05-28
Affected packages
• Packagist silverstripe/framework: >= 4.0.0-rc1, < 4.0.6 → fixed in 4.0.6
• Packagist silverstripe/framework: >= 4.1.0-rc1, < 4.1.4 → fixed in 4.1.4
• Packagist silverstripe/framework: >= 4.2.0-rc1, < 4.2.3 → fixed in 4.2.3
Description
A potential SQL injection vulnerability was identified by using the silverstripe/postgresql database adapter. While unlikely to be exploitable, we have patched silverstripe/framework to ensure that table names are safely escaped before being passed to database adapters or user code.
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/silverstripe/silverstripe-framework/commit/48bd335648188df9dae72be1e5f9c808f3fe1e77 web
- https://github.com/silverstripe/silverstripe-framework/commit/fecedc2d98eeaaff6424fb59dc70ef6bdc6dc92d web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2018-020-1.yaml web
- https://github.com/silverstripe/silverstripe-framework package
- https://www.silverstripe.org/download/security-releases/ss-2018-020 web