GitHub Advisoryadvisory · Packagist

GHSA-267j-cwvg-j28c Moodle attackers to modify grade metadata

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-2572
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: >= 2.6.0, < 2.6.2 → fixed in 2.6.2

Description

mod/assign/externallib.php in Moodle 2.6.x before 2.6.2 does not properly handle assignment web-service parameters, which might allow remote authenticated users to modify grade metadata via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2014-2572 mod/assign/externallib.php in Moodle 2.6.x before 2.6.2 does not properly handle assignment web-service parameters, which might allow… vulnerability

References