GitHub Advisoryadvisory · PyPI
GHSA-2689-cw26-6cpj Whoogle allows attackers to execute arbitrary code via supplying a crafted search query
HIGH
Official page ↗
- Aliases
- CVE-2024-53305
- Ecosystem
- PyPI
- Packages
- whoogle-search
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- Weaknesses
- CWE-78
- Reviewed
- 2025-04-16
Affected packages
• PyPI whoogle-search: < 0.9.1 → fixed in 0.9.1
Description
An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to execute arbitrary code via supplying a crafted search query.
Related
Alias · CVE (1)
- CVE-2024-53305 An issue in the component /models/config.py of Whoogle search v0.9.0 allows attackers to execute arbitrary code via supplying a crafted… vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-53305 advisory
- https://github.com/benbusby/whoogle-search/commit/223f00c3c0533423114f99b30c561278bc0b42ba web
- https://fern89.github.io/posts/whoogle-rce web
- https://gist.github.com/fern89/ca5fe76ad81b4bc363e7341e523a1651 web
- https://github.com/benbusby/whoogle-search package