GitHub Advisoryadvisory · Maven

GHSA-269m-695x-j34p Apache Qpid Broker vulnerable to authentication port spoofing

CRITICAL Published 2018-10-19 Modified 2023-08-28 Official page ↗
Aliases
CVE-2017-15702
Ecosystem
Maven
Packages
org.apache.qpid:qpid-broker
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2020-06-16

Affected packages

• Maven org.apache.qpid:qpid-broker: >= 0.18, < 6.0.0 → fixed in 6.0.0

Description

Apache Qpid Broker-J versions 0.18 through 0.32 are vulnerable to authentication port spoofing. When the broker is configured with different authentication providers on different ports, one of which is an HTTP port, then the broker can be tricked by a remote unauthenticated attacker connecting to the HTTP port into using an authentication provider that was configured on a different port. The attacker still needs valid credentials with the authentication provider on the spoofed port. This becomes an issue when the spoofed port has weaker authentication protection (e.g., anonymous access, default accounts) and is normally protected by firewall rules or similar which can be circumvented by this vulnerability. AMQP ports are not affected.

Related

Alias · CVE (1)

  • CVE-2017-15702 In Apache Qpid Broker-J 0.18 through 0.32, if the broker is configured with different authentication providers on different ports one of… vulnerability

References