GitHub Advisoryadvisory · RubyGems
GHSA-26qj-cr27-r5c4 Octopoller gem published with world-writable files
LOW
Official page ↗
- Aliases
- CVE-2022-31071
- Ecosystem
- RubyGems
- Packages
- octopoller
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-276
- Reviewed
- 2022-06-15
Affected packages
• RubyGems octopoller: >= 0.2.0, < 0.3.0 → fixed in 0.3.0
Description
Impact
Version 0.2.0 of the octopoller gem was published containing world-writeable files. Specifically, the gem was packed with files having their permissions set to `-rw-rw-rw-` (i.e. 0666) instead of `rw-r--r--` (i.e. 0644).
This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem.
Malicious code already present and running on your machine, separate from this package, could modify the gem’s files and change its behavior during runtime.
Patches
• octopoller 0.3.0
Workarounds
Users can use the previous version of the gem v0.1.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.
Related
Alias · CVE (1)
- CVE-2022-31071 Octopoller is a micro gem for polling and retrying. vulnerability
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness
References
- https://github.com/octokit/octopoller.rb/security/advisories/GHSA-26qj-cr27-r5c4 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31071 advisory
- https://github.com/octokit/octopoller.rb/commit/abed2b8d05abe2cc3eb6bdfb34e53d465e7c7874 web
- https://github.com/octokit/octopoller package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/octopoller/CVE-2022-31071.yml web