GitHub Advisoryadvisory · Maven

GHSA-26v6-w6fw-rh94 Apache Camel can allow remote attackers to execute arbitrary commands

HIGH Published 2018-10-16 Modified 2023-12-19 Official page ↗
Aliases
CVE-2015-5348
Ecosystem
Maven
Packages
org.apache.camel:camel-jetty, org.apache.camel:camel-servlet, org.apache.camel:camel-http, org.apache.camel:camel-http-common, org.apache.camel:camel-http4, org.apache.camel:camel-ahc
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2020-06-16

Affected packages

• Maven org.apache.camel:camel-jetty: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-jetty: >= 2.16.0, < 2.16.1 → fixed in 2.16.1 • Maven org.apache.camel:camel-servlet: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-servlet: >= 2.16.0, < 2.16.1 → fixed in 2.16.1 • Maven org.apache.camel:camel-http: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-http: >= 2.16.0, < 2.16.1 → fixed in 2.16.1 • Maven org.apache.camel:camel-http-common: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-http-common: >= 2.16.0, < 2.16.1 → fixed in 2.16.1 • Maven org.apache.camel:camel-http4: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-http4: >= 2.16.0, < 2.16.1 → fixed in 2.16.1 • Maven org.apache.camel:camel-ahc: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-ahc: >= 2.16.0, < 2.16.1 → fixed in 2.16.1

Description

Apache Camel 2.6.x through 2.14.x, 2.15.x before 2.15.5, and 2.16.x before 2.16.1, when using (1) camel-jetty or (2) camel-servlet as a consumer in Camel routes, allow remote attackers to execute arbitrary commands via a crafted serialized Java object in an HTTP request.

Related

Alias · CVE (1)

  • CVE-2015-5348 Apache Camel 2.6.x through 2.14.x, 2.15.x before 2.15.5, and 2.16.x before 2.16.1, when using (1) camel-jetty or (2) camel-servlet as a… vulnerability

References