GitHub Advisoryadvisory · Packagist
GHSA-273w-7fxj-pcp6 Moodle vulnerable to Uncontrolled Resource Consumption
HIGH
Official page ↗
- Aliases
- CVE-2021-36395
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400, CWE-674
- Reviewed
- 2023-03-07
Affected packages
• Packagist moodle/moodle: >= 3.11.0-beta, < 3.11.1 → fixed in 3.11.1
• Packagist moodle/moodle: >= 3.10.0-beta, < 3.10.5 → fixed in 3.10.5
• Packagist moodle/moodle: < 3.9.8 → fixed in 3.9.8
Description
In Moodle, the file repository's URL parsing required additional recursion handling to mitigate the risk of recursion denial of service.
Related
Alias · CVE (1)
- CVE-2021-36395 In Moodle, the file repository's URL parsing required additional recursion handling to mitigate the risk of recursion denial of service. vulnerability