GitHub Advisoryadvisory · Packagist
GHSA-275c-v3rc-xghx Kirby XSS Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2017-16807
- Ecosystem
- Packagist
- Packages
- getkirby/cms
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-26
Affected packages
• Packagist getkirby/cms: < 2.3.3 → fixed in 2.3.3
• Packagist getkirby/cms: >= 2.4, < 2.4.2 → fixed in 2.4.2
• Packagist getkirby/cms: >= 2.5, < 2.5.7 → fixed in 2.5.7
Description
A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.
Related
Alias · CVE (1)
- CVE-2017-16807 A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness