GitHub Advisoryadvisory · Packagist

GHSA-277f-37gw-9gmq raspap-webgui has a Directory Traversal vulnerability

HIGH Published 2025-06-27 Modified 2025-06-27 Official page ↗
Aliases
CVE-2025-44163
Ecosystem
Packagist
Packages
billz/raspap-webgui
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
Weaknesses
CWE-22, CWE-23
Reviewed
2025-06-27

Affected packages

• Packagist billz/raspap-webgui: < 3.3.6 → fixed in 3.3.6

Description

RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the `entity` parameter to overwrite arbitrary files writable by the web server via abuse of the `tee` command used in shell execution.

Related

Alias · CVE (1)

  • CVE-2025-44163 RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. vulnerability

Weakness · CWE (2)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
  • CWE-23 Relative Path Traversal weakness

References