GitHub Advisoryadvisory · PyPI

GHSA-27jx-ffw8-xrqv pgAdmin Remote Code Execution (RCE) vulnerability

HIGH Published 2024-04-04 Modified 2025-02-11 Official page ↗
Aliases
CVE-2024-3116
Ecosystem
PyPI
Packages
pgadmin4
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weaknesses
CWE-77
Reviewed
2024-04-04

Affected packages

• PyPI pgadmin4: < 8.5 → fixed in 8.5

Description

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

Related

Alias · CVE (1)

  • CVE-2024-3116 pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References