GitHub Advisoryadvisory · Packagist
GHSA-27vf-3g4f-6jp7 LibreNMS Ports Stored Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-23199
- Ecosystem
- Packagist
- Packages
- librenms/librenms
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-01-16
Affected packages
• Packagist librenms/librenms: < 24.11.0 → fixed in 24.11.0
Description
StoredXSS-LibreNMS-Ports
Description:
Stored XSS on the parameter:
`/ajax_form.php` -> param: descr
Request:
```http
POST /ajax_form.php HTTP/1.1
Host:
X-Requested-With: XMLHttpRequest
X-CSRF-TOKEN:
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
Cookie:
type=update-ifalias&descr=%22%3E%3Cimg+src+onerror%3D%22alert(1)%22%3E&ifName=lo&port_id=1&device_id=1
```
of Librenms version 24.10.1 (https://github.com/librenms/librenms) allows remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure.
Proof of Concept:
1. Add a new device through the LibreNMS interface.
2. Edit the newly created device and select the "ports" section.
3. In the "Description" field, enter the following payload: `">`.
4. Save the changes.
5. The XSS vulnerability is triggered when accessing the "ports" tab, and the payload is executed again when hovering over the modified value in the "Port" field.
Payload:
Executes:
The script execution vulnerability in the description field, as shown in the image, occurs at Line 63 of functions.inc.php
```php
$overlib_content = '' . $text . '';
```
Impact:
Execution of Malicious Code
Related
Alias · CVE (1)
- CVE-2025-23199 librenms is a community-based GPL-licensed network monitoring system. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/librenms/librenms/security/advisories/GHSA-27vf-3g4f-6jp7 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-23199 advisory
- https://github.com/librenms/librenms/pull/16721 web
- https://github.com/librenms/librenms/commit/9d07d166b87634091dcf21c62b28f9b42a3118c4 web
- https://github.com/librenms/librenms package