GitHub Advisoryadvisory · Maven

GHSA-27vm-5vpj-rp5g Apache Camel Vulnerable to Authentication Bypass Using an Alternate Path or Channel

HIGH Published 2026-04-27 Modified 2026-05-05 Official page ↗
Aliases
CVE-2026-40022
Ecosystem
Maven
Packages
org.apache.camel:camel-platform-http-main
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-288
Reviewed
2026-05-05

Affected packages

• Maven org.apache.camel:camel-platform-http-main: >= 4.14.1, < 4.14.6 → fixed in 4.14.6 • Maven org.apache.camel:camel-platform-http-main: >= 4.18.0, < 4.18.2 → fixed in 4.18.2 • Maven org.apache.camel:camel-platform-http-main: >= 4.19.0, < 4.20.0 → fixed in 4.20.0

Description

When authentication is enabled on the Apache Camel embedded HTTP server or embedded management server (camel-platform-http-main) and a non-root context path such as /api or /admin is configured via camel.server.path or camel.management.path, the BasicAuthenticationConfigurer and JWTAuthenticationConfigurer classes derive the authentication path from properties.getPath() when camel.server.authenticationPath / camel.management.authenticationPath is not explicitly set. Combined with the Vert.x sub-router mounting model - the sub-router is mounted at _path_* and the authentication handler is registered inside the sub-router at the resolved path - this causes the authentication handler to match only the exact configured context path, not its subpaths. Unauthenticated requests to subpaths such as /api/_route_ or /admin/observe/info therefore reach protected business routes and management endpoints without being challenged for credentials. The /observe/info endpoint can disclose runtime metadata such as the user, working directory, home directory, process ID, JVM and operating system information. This issue affects Apache Camel: from 4.14.1 before 4.14.6, from 4.18.0 before 4.18.2. Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, they are suggested to upgrade to 4.14.6. If users are on the 4.18.x LTS releases stream, they are suggested to upgrade to 4.18.2.

Related

Alias · CVE (1)

  • CVE-2026-40022 When authentication is enabled on the Apache Camel embedded HTTP server or embedded management server (camel-platform-http-main) and a… vulnerability

Weakness · CWE (1)

  • CWE-288 Authentication Bypass Using an Alternate Path or Channel weakness

References