GitHub Advisoryadvisory · NuGet
GHSA-2865-hh9g-w894 Microsoft Security Advisory CVE-2025-24070: .NET Elevation of Privilege Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-24070
- Ecosystem
- NuGet
- Packages
- Microsoft.AspNetCore.Identity, Microsoft.AspNetCore.App.Runtime.linux-arm, Microsoft.AspNetCore.App.Runtime.linux-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-arm, Microsoft.AspNetCore.App.Runtime.linux-musl-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-x64, Microsoft.AspNetCore.App.Runtime.linux-x64, Microsoft.AspNetCore.App.Runtime.osx-arm64, Microsoft.AspNetCore.App.Runtime.osx-x64, Microsoft.AspNetCore.App.Runtime.win-arm, Microsoft.AspNetCore.App.Runtime.win-arm64, Microsoft.AspNetCore.App.Runtime.win-x64, Microsoft.AspNetCore.App.Runtime.win-x86
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
- Weaknesses
- CWE-1390
- Reviewed
- 2025-03-11
Affected packages
• NuGet Microsoft.AspNetCore.Identity: >= 2.3.0, < 2.3.1 → fixed in 2.3.1
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.osx-arm64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.osx-arm64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 8.0.0, < 8.0.14 → fixed in 8.0.14
• NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 9.0.0, < 9.0.3 → fixed in 9.0.3
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.osx-arm64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 6.0.0, <= 6.0.36 (no fix yet)
• NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 6.0.0, <= 6.0.36 (no fix yet)
Description
Microsoft Security Advisory CVE-2025-24070: .NET Elevation of Privilege Vulnerability
Executive summary
Microsoft is releasing this security advisory to provide information about a vulnerability in ASP.NET Core 9.0, ASP.NET Core 8.0, ASP.NET Core 6.0, and ASP.NET Core 2.3. This advisory also provides guidance on what developers can do to update their applications to address this vulnerability.
A vulnerability exists in ASP.NET Core applications calling RefreshSignInAsync with an improperly authenticated user parameter that could allow an attacker to sign into another user's account, resulting in Elevation of Privilege.
Announcement
Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/348
Mitigation factors
Microsoft has not identified any mitigating factors for this vulnerability.
Affected software
• Any ASP.NET Core 9.0 application running on ASP.NET Core 9.0.2 or earlier.
• Any ASP.NET Core application running on ASP.NET Core 8.0.13 or earlier.
• Any ASP.NET Core application running on ASP.NET Core 6.0.36 or earlier.
• Any ASP.NET Core 2.x application consuming the package Microsoft.AspNetCore.Identity version 2.3.0 or earlier.
Affected Packages
The vulnerability affects any Microsoft .NET Core project if it uses any of affected packages versions listed below
| Package name | Affected version | Patched version |
| --- | --- | --- |
| Microsoft.AspNetCore.Identity | 2.3.0 | 2.3.1 |
ASP.NET Core 9
| Package name | Affected version | Patched version |
| --- | --- | --- |
| Microsoft.AspNetCore.App.Runtime.linux-arm | >= 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, = 6.0.0, <= 6.0.36 | none |
Advisory FAQ
How do I know if I am affected?
If you have a runtime or SDK with a version listed, or an affected package listed in affected software or affected packages, you're exposed to the vulnerability.
How do I fix the issue?
1. To fix the issue please install the latest version of .NET 9.0. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
2. If your application references the vulnerable package, update the package reference to the patched…
Related
Alias · CVE (1)
- CVE-2025-24070 Weak authentication in ASP.NET Core & Visual Studio allows an unauthorized attacker to elevate privileges over a network. vulnerability
Weakness · CWE (1)
- CWE-1390 Weak Authentication weakness
References
- https://github.com/dotnet/aspnetcore/security/advisories/GHSA-2865-hh9g-w894 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-24070 advisory
- https://github.com/dotnet/aspnetcore package
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2025-24070 web
- https://www.herodevs.com/vulnerability-directory/cve-2025-24070 web