GitHub Advisoryadvisory · npm

GHSA-2877-693q-pj33 OS Command Injection in GenieACS

CRITICAL Published 2022-03-07 Modified 2022-03-14 Official page ↗
Aliases
CVE-2021-46704
Ecosystem
npm
Packages
genieacs
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-78
Reviewed
2022-03-07

Affected packages

• npm genieacs: < 1.2.8 → fixed in 1.2.8

Description

In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.

Related

Alias · CVE (1)

  • CVE-2021-46704 In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument… vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References